Pacific Supernet blocks port 25 for other SMTP servers

Reply
  1. #1

    Join Date
    Jul 2007
    Location
    TST and Macau
    Posts
    1,428

    Pacific Supernet blocks port 25 for other SMTP servers

    I dont't want to use Pacific Supernet's SMTP server while being connected through them as an ISP. They block port 25 for other SMTP servers.

    The reason: I use my own domain's email address hosted overseas. If I use an SMTP server other than the one of my domain host, many spam filters regard my mails as spam just only for this reason. Any solution.


  2. #2

    Join Date
    Jun 2005
    Location
    Hong Kong
    Posts
    23,217

    Are you sure about the blocking? For example, I use Netvigator's SMTP server for all my emails, and 90% of them are on non-Netvigator domains.

    To the best of my knowledge none of my emails has been spam-blocked.

    Is Pacific Internet's SMTP server unauthenticated and or open to relaying? If so that might be the reason you are being blocked, not the difference in domains per se.


  3. #3

    Join Date
    Mar 2007
    Posts
    13,150

    Many ISPs block port 25 -- its normal and not unusual at all.
    In HonKong, Netvigator (the biggest) blocks 25
    In the US, Earthlink (one of the biggest) blocks 25

    Ask your webhost about this. As this is such a common things, most providers will open 587 for client authenticated SMTP.

    As for the spam comment : Bad/Stupid filters are everywhere -- educating the admins and users can help at times.

    HC


  4. #4

    Join Date
    Jul 2007
    Location
    TST and Macau
    Posts
    1,428
    Quote Originally Posted by HowardCoombs:
    Many ISPs block port 25 -- its normal and not unusual at all.
    In HonKong, Netvigator (the biggest) blocks 25
    In the US, Earthlink (one of the biggest) blocks 25

    Ask your webhost about this. As this is such a common things, most providers will open 587 for client authenticated SMTP.

    As for the spam comment : Bad/Stupid filters are everywhere -- educating the admins and users can help at times.

    HC
    I use 587 already for one provider, but for the other it doesn't work unluckily.

  5. #5

    Join Date
    Sep 2007
    Posts
    78

    A hint to overcome port blocking

    Hi folks,


    Just joined this form and found this thread.

    It happens that I am running pacific.net.hk as ISP. Most ISPs blocks port 25 and 80, the former being mail port and the latter for https. If you subscribe fixed IP plan you can request pacific.net.hk to uplift port 25 and 80.

    For domestic subscribers with dynamic IP pacific.net.hk won't entertain such a request. To overcome the barrier, for mail you can relay their mail server sending emails. For https you can use port 8080.

    HTH


    B.R.
    satimis

    Last edited by satimis; 07-09-2007 at 12:18 PM.

  6. #6

    Join Date
    Jun 2006
    Posts
    2,163
    Quote Originally Posted by satimis:
    It happens that I am running pacific.net.hk as ISP. Most ISPs blocks port 25 and 80, the former being mail port and the latter for https. If you subscribe fixed IP plan you can request pacific.net.hk to uplift port 25 and 80.
    Hey champ good job reading, the OP is talking about outgoing ports not incoming.

    The standard SSL SMTP port is 465, try that instead of 587.

  7. #7

    Join Date
    Sep 2007
    Posts
    78
    Quote Originally Posted by MrMoo:
    Hey champ good job reading, the OP is talking about outgoing ports not incoming.

    The standard SSL SMTP port is 465, try that instead of 587.
    Hi MrMoo,

    Tks for your advice.

    While I was running Dynamic IP previously I sent mails via relaying ISP's mail server even port 25 blocked.

    I'm now running fixed IP so pacific.net.hk uplift port 25 upon my request.


    B.R.
    satimis

  8. #8

    Join Date
    Jan 2008
    Location
    Hong Kong
    Posts
    1

    Outgoing Server Settings

    Hi guys,
    I am new to Hong Kong, and it amazes me that in this day and age an ISP has managed to complicate the outgoing server settings beyond the realms of reality!
    I appreciate the suggestion to go to NETVIGATOR -- Customer Service and my problems will be solved, I wish it were that simple, I use thunderbird, I enter the famous smtp.netvigator.com in my outgoing server settings, (I even tried ndsmtp.netvigator.com, no use) port 25, with a working user name and password.

    All my email is non-netvigator domains and the strange thing is I am receiving all my email from these domains perfectly, its just the sending part that has me snookered, anyone who could shed some light on this for me, it would be much appreciated.
    Cheers
    Scott


  9. #9

    Join Date
    Apr 2003
    Posts
    12,384

    Your username has to be in the format "[email protected]" or whatever was assigned to you - preferably the same as your PPoE login.