Sending non-Netvigator mail with Netvigator on a Mac

  1. #1

    Join Date
    Jul 2008
    Tai Kok Tsui

    Sending non-Netvigator mail with Netvigator on a Mac

    Tried several times replying to the thread :"" but my post just wouldn't show. Maybe the thread is too old.

    I'll start a new thread here.

    Quote Originally Posted by tsuiwah:
    Not sure what KIA's link says, but I had the same problem (and couldn't get an answer via their site) and a phone call to them solved the problem in less than 5 minutes.
    No luck on the telephones for me. They told me to use "" as outgoing server, which didn't work at all. They also kept telling me port 25 is blocked, yet when I asked "which port should I use then?" they couldn't give me an answer. Mr Moo thanks for the screenshots above, but I suspect PC users don't have to worry about filling in the Port numbers.

    I got my answer from Shri of this here forums. Decided to sign up since Shri assures me Geoexpats don't bite ;-) I know this thread is 2yrs old, but I hope someone benefits from this!
    Pictures attached.

    I was concerned that my mails would show it's from "[email protected]" but it doesn't..I tested it and it shows sender as "[email protected]".


  2. #2

    You could try to use SSL - then you don't have to use PCCWs outgoing mail server, you can use your own. (I don't use theirs)

    You have to set outgoing mail server to your own outgoing address then under server settings set the outgoing port to 465 with SSL.

    You can also set the incoming server to use SSL the port is usually 995.

    Alternatively, your mail server may use another port too because of this port 25 blocking issue. Mine uses port 26 and that gets through nevigator OK. Another outgoing port sometimes used is 2525.

    If you use gmail they use SSL and probably have instructions how to set it up on a Mac

    Last edited by zerocred; 10-12-2008 at 02:30 PM.

  3. #3

    Join Date
    Apr 2006
    Kwun Tong

    If I may blatantly plug my company. We have solve this issue a long time ago for all our mac users. This is fixed by using us.

    The problems are that Entourage and maybe Mac Mail (what ever it is called) get upset when they are given the SMTP auth encryption options in the wrong order. THey use the first one presented and don't implement it properly.

    To bypass any filters you are behind off you can also reach our SMTP/POP/IMAP servers in a variety of non-Standard ports, with and without SSL

    Good luck.