Like Tree15Likes

Keyboard and spelling - different English

Closed Thread
Page 1 of 4 1 2 3 4 LastLast
  1. #1

    Join Date
    Oct 2006
    Location
    Sarcasm - because beating the crap out of people is illegal
    Posts
    14,622

    Keyboard and spelling - different English

    First I've dug around the interwebs and this is a problem that seems to only have one solution, or at least people asking are happy with that one solution. Anyway...

    Does anyone know how one can have a US-English keyboard layout but UK-English spelling on a Windows 7-based PC?

    The US keyboard layout has the $ # etc. signs in the right place but 'insists' on misspelling everything - and I don't have time or inclination to change the language for every email and document 'manually'. On the UK keyboard layout, the keys are all over the places thus different from the physical (US) keyboard.

    At the moment I have the US-International keyboard layout and UK English spelling but with this there are problems with dead keys and others behaving badly.

    Can anyone help me to end this torture?


  2. #2

    Join Date
    Oct 2006
    Location
    Sarcasm - because beating the crap out of people is illegal
    Posts
    14,622

    It's not the keyboard. The physical keyboard is fine. It's working out how to have two options that 'computer says no' to.


  3. #3

    Join Date
    Dec 2013
    Location
    Hong Kong
    Posts
    12,333

    Get a mac. I'm pretty sure my keyboard layout is US but all my settings are UK and it seems to work fine! Having said that, it used to work fine having UK spelling (in the Word - Settings - Spelling and Grammar) set up in Word with a US keyboard.

    Is it not solvable by setting up your language settings in each programme (such as Word, email etc) to UK or has Bill in his infinite wisdom decided all language/location settings are to be handled by one command?


  4. #4

    Join Date
    Aug 2006
    Posts
    11,884

    Region and Language, Formats tab = "English (United Kingdom)" Your Office settings should follow this by default.

    Region and Language, Keyboard and Languages tab = "US". And check in this window that English "United Kingdom" is the only option, with the US keyboard underneath it.

    Sometimes US English remains as a secondary option- if you see this anywhere, remove it.

    To be honest, I am a little confused by your question... you have a US keyboard and UK language settings (a very common setup), but you have dead keys? I haven't come across this before. Are you sure there is not a physical fault with the keyboard?

    Last edited by jgl; 10-06-2014 at 03:22 PM. Reason: Corrected a typo: Ironically the word "English" had been misspelled.

  5. #5

    Join Date
    Oct 2006
    Location
    Sarcasm - because beating the crap out of people is illegal
    Posts
    14,622

    Thanks jgl. Before I saw your post, I tried Singapore English and keyboard layout. I have to use 'la' at the end of every sentence but otherwise it's good... la.

    The keyboard is fine. The main dead key was the right-hand ALT key, but also the quotation marks key only worked if you hit it twice, and then of course I'd get double "" or ' '. Seems that both are problems others have had, according to the webs... la.


  6. #6

    The quotes key thing is how European keyboard configs put accents over letters (try "a and you get ä, for example). You need to type "<space> to get a straight quote.


  7. #7

    Join Date
    Dec 2010
    Location
    Wrong side of the door to hell
    Posts
    6,079

    I have a US keyboard, set to UK configuration (I dislike where the @ key is on US layout, also no accents on US layout (or is that Uk English setting that lets me do that?), plus I have always typed on a UK layout) with UK English. I can never remember how I did it, so thanks JGL!

    Now if only we could get Geoexpat to stop putting the red lines under UK spelling....

    Last edited by kimwy66; 10-06-2014 at 05:47 PM.

  8. #8

    Join Date
    Oct 2006
    Location
    Sarcasm - because beating the crap out of people is illegal
    Posts
    14,622
    Quote Originally Posted by Fleetingly:
    ...You need to type "<space> to get a straight quote.
    No, I don't need to type that. What I need is for Microsoft to go back to supporting XP... la


  9. #9

    The key is to set your keyboard layout to plain US, not US-International


  10. #10

    Join Date
    Dec 2002
    Location
    薄扶林
    Posts
    48,469

    XP support, cannot la.

    kimwy66 and Claire ex-ax like this.

Closed Thread
Page 1 of 4 1 2 3 4 LastLast